'Invalid column name' error (code 260) for every join

I've created a data set in my trial space on the Warehouse Cloud using CSV uploads which consists of 5 tables out of which one is a transaction data table, one master data, 2 text tables and one mapping table to link master and transaction data.

The idea was to create an attribute view by joining the master data and text tables, a second view by joining the transaction and mapping data tables and then bring all these views together in an analytical view.

However I'm having trouble getting even a single join to work. Every single join throws an 'Invalid column name (code 260)' error even though there are no such errors in the underlying tables. There is no information on how to resolve these errors. Any advice on how to proceed would be very welcome.

Thanks


Best Answer

«1

Answers

  • Can you post screenshots of your join nodes?

  • edited December 2019

    Hi @Ram,

    Sorry you're having such a hard time getting your view to work...

    There isn't a lot to go on from the screenshots, but I can see some areas that might cause this problem.

    1) Did you have multiple tries before you got the CSV to load? Was the last version deployed? It might be good to redo the final version with a new technical name, just to make sure you have only one version of it.

    2) I see you use different case settings for your column names (Case_Type in CASE_PL_MAP and CASE_TYPE in CASE_HEADER). It's a good practice to choose one and stick to it so you have no doubts about the names.

    3) Maybe the ER model will help you to get more of an overview, Here you can see all columns that are in each table, So you can quickly spot what might be the problem.

    If you've done all that and still have this same error, please create an OSS message, so support/development can have a look what could be bugging you.

    Thanks! Marianne

  • @Sven Knoepfler here's a screenshot of the join, Hope this rings some bell:


  • Hi @Marianne van Loenen (Marianne) ,


    Thanks for the detailed response. I'll try and address each point:

    1) I did take multiple tries uploading the CSV. It was a large dataset and I kept missing some date/time records while putting them in the right format for SAP. However once the CSVs were ready, I deleted all the previous tables from the warehouse cloud and reloaded every table afresh.

    2) I understand this kind of naming is convention and affects proposed joins, but I'm familiar with the schema and made my joins myself. Nevertheless, I initially made sure all the column names matched across tables but the same error (26). It was only after multiple tries deleting and reloading the tables that I gave up trying to get the column names to match and started looking for other causes.

    3) I'm intimately familiar with all the columns in each of these tables since I've been working with this schema for a while. Doesn't seem to be a problem with the data itself or the table definitions. I even reviewed the data output in the warehouse cloud for each table individually, and there were no error messages or missing records in any of the tables.


    Regarding your suggestion of creating an OSS note, would you please guide me on how I can go about doing that? My SAP Help account doesn't list the Warehouse Cloud as one of the systems linked to my ID.

    Thanks, Ram

  • @Ram : thanks for the screenshots. the join looks fine. Did you check the projection node afterwards? Maybe there is are now two columns with the same technical name and you have to exclude one? otherwise you can always add my user [email protected] to you trial account and I have a look at it myself if you like.

    Cheers

  • Thanks a bunch for your offer, @Sven Knoepfler! I really appreciate it.

    I've added your email ID to my account, although I'm not sure whether I've done it right. Here's some screenshots

    Meanwhile I'll heed your advice and review my projection view.


  • @Ram: I can login to your DWC, but you still need to add me to your space, otherwise I cannot access your data models. Cheers

  • @Ram : i pressed deploy on your model and it worked without any modification. So unfortunately I cannot tell you why it didnt work before as I cannot reproduce your error. At least it works now... Hope you can go on now.

  • Thanks @Sven Knoepfler!

    I used the view that you fixed to finalise my Case dimension. Moved on to creating an analytical view using the rest of the tables, but got stuck again with error 160 in the new view. The deploy trick doesn't seem to do the trick this time around.

Sign In or Register to comment.