Unable to deploy CSV files with decimals

edited October 2019 in General Discussions

Hi all,

When deploying a CSV file with decimals, I am getting the following message:

After pressing "Truncate & Deploy", no data is uploaded:

I have tried with all the available types: Decimal, DecimalFloat, etc.

Has anyone been able to upload CSV files with decimals?

Many thanks in advance,

Carlos

Tagged:

Best Answer

Answers

  • Jascha KanngiesserJascha Kanngiesser Product Manager, Data Warehousing, SAP SE Walldorf, Germany mod

    Hi Carlos,

    I assume that you did the following steps:

    1. Upload CSV file via "Import CSV File" option without changing the data types in the "Import CSV File" dialog.
    2. After uploading the data, in the table editor of the newly created local table, you changed the type from STRING(5000) to something different like INTEGER or Decimal, and received the prompt asking for a truncate & deploy.
    3. After selecting "Truncate & Deploy", the data types where correctly changed, but the table was empty. Now you're looking for a way to upload the data again, right?

    From the "Edit" menu you have the option to upload data to the table again after you made the changes:

    That should allow you to fill the table again, this time using the right data types.

  • Hi Jascha,

    I also tried that, but if I re-deploy the table after making the changes and re-uploading the data, there is no data again:

    Thank you,

    Carlos

  • Jascha KanngiesserJascha Kanngiesser Product Manager, Data Warehousing, SAP SE Walldorf, Germany mod

    Have you refreshed the page completely? I just tried it in another customer tenant and it was working fine.

  • Yes, I have. It is an infinite loop, every time I deploy I have to upload the data again.

    Is it really necessary to deploy after uploading the data?

  • Ashok KaradagattaAshok Karadagatta SAP BI/HANA Lead Consultant India

    I had similar issue.

    If you open up a table you previously created with data loaded into it, you cannot change the column datatypes. Even if you first truncate the data from the table. It seems as if you must recreate the table.

    I think issue is with the refresh.

    Thanks & Regards,

    Ashok Karadagatta

  • Hi Ashok,

    As Jascha said, you don't need to recreate the table, you can change the data types, then "Truncate and deploy" and then upload the data again.

    What we are discussing now is whether it is needed to deploy again after uploading the data.

    Thank you,

    Carlos

  • Beat HoneggerBeat Honegger Senior BI-Consultant Winterthur - Switzerland

    Hello Carlos

    In the csv: Did you use '.' or ',' as a sperator?

    When I use '.' it is working fine, with the ',' it will truncate after the decimal seperater.

    12.3 -> 12.3

    12,3 -> 12.0

    Beat

  • Many thanks for your answer @Jascha Kanngiesser, it is clear now.

Sign In or Register to comment.